Jump to content
  • 1
Sign in to follow this  
evoc

Задержка в начале спама кнопки

Question

Начало спама клавиши происходит не сразу а с задержкой. Обратите внимание когда меняется клавиша - печатается 1-2 символа -  потом задержка - потом спам.

на видео я вжимаю кнопки по очереди, не отпуская предыдущую вжимаю следующую. 

макросы которые я использую:

mac.jpg.14dfe3e1a8d2cf7ab6d10a962bb91d4a.jpg

Режим работы : "Выполнять пока нажата клавиша"

Привязка к окнам отключена, использование драйвера.

 

если выключить BM и подшаманить настройки винды можно добиться вот такого результата:

на втором видео BM выключен, настройки реестра как на картинке (только AutoRepeatDelay 30 а не 200)reg.thumb.jpg.0ae2de5e722ebbc5a0ecc4ddc08efd35.jpg

собственно цель - сделать так что бы при AutoRepeatDelay=200 и включенным BM спам начинался сразу без задержек.

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Я понял, то есть проблема в прерывании макроса. Я посмотрю в чем может быть проблема и если это будет технически быстро сделать исправлю в ближайшее время, если для этого понадобится значительная переработка кода, тогда включу в планы на баг-фиксы будущих обновлений.

Share this post


Link to post
Share on other sites
  • 0

эта опция включена

Share this post


Link to post
Share on other sites
  • 0

отключил - все тоже самое. задержка не поменялась.

Share this post


Link to post
Share on other sites
  • 0

есть какие-то идеи? или прога фактически бесполезна для спама?

Share this post


Link to post
Share on other sites
  • 0

evoc если я правильно понял: макрос у вас выполняет только нажатие клавиши 1? А на какую клавишу присвоен этот макрос? И почему на видео я вижу нажатие клавиш 2 и 3 если в макросе нажимается только цифра 1?

Share this post


Link to post
Share on other sites
  • 0

evoc и проблема в том, что при нажатии клавиши на которую срабатывает макрос этот макрос срабатывает не сразу а с определенной задержкой в начале, верно?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
5 часов назад, Nalik сказал:

evoc если я правильно понял: макрос у вас выполняет только нажатие клавиши 1? А на какую клавишу присвоен этот макрос? И почему на видео я вижу нажатие клавиш 2 и 3 если в макросе нажимается только цифра 1?

макрос который показан на скрине присвоен кнопке 1. аналогично с кнопками 2 3 - там такие же макросы только на свои кнопки.

5 часов назад, Nalik сказал:

evoc и проблема в том, что при нажатии клавиши на которую срабатывает макрос этот макрос срабатывает не сразу а с определенной задержкой в начале, верно?

если просто нажать на кнопку - работает отлично - сразу начинается спам без задержек. проблема появляется если жать одну кнопку и потом нажать другую в это же время отпуская первую. 

я думал что это "переспам" и пробовал ставить бОльшие задержки или добавлять задержки в начале или вконце макроса - но это не помогло. единственное что помогло это настройка в реестре залипания клавиш(то что на 2 видео). но проблема в том что с ней не возможно вообще что-то делать на компьютере(на виедо даже видно как чат появляется несколько раз потому что даже кнопка ентер прокликивает).

 

пс в целом настройка винды не так и страшна если ее можно было бы отключать и включать вместе с остальными макросами. то есть когда я жму скилы я включаю макросы/спам, когда я пишу в чат я выключаю все это. если есть возможность включать эту настройку с макросами "на лету" - такое решение подойдет.

Edited by evoc

Share this post


Link to post
Share on other sites
  • 0
13 часов назад, Nalik сказал:

Я понял, то есть проблема в прерывании макроса. Я посмотрю в чем может быть проблема и если это будет технически быстро сделать исправлю в ближайшее время, если для этого понадобится значительная переработка кода, тогда включу в планы на баг-фиксы будущих обновлений.

спасибо

Share this post


Link to post
Share on other sites
  • 0

есть какая-то информация по проблеме? получится пофиксить?

Share this post


Link to post
Share on other sites
  • 0
45 минут назад, evoc сказал:

есть какая-то информация по проблеме? получится пофиксить?

Ещё работаем 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Chatbox

    You don't have permission to chat.
    Load More
×